Clicky

Pre-requists for running AZInsight on Chrome browser

In order to run AZInsight you need to have:

  • the latest version of the Google Chrome browser installed 
  • the latest version of AZInsight chrome extension

If after updating both the chrome browser and extensions you still do not see AZInsight show up please check the following: 

If you are still experiencing issues having AZInsight show up please click on the live chat button on the support home page to chat with a Customer Champion.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us