Why do I see an error page with dogs when I use Amazon?

Why do I see an error page with dogs when I use Amazon?

This means that Amazon has flagged your Internet Address (IP) as a bot. Below we list some of the possible causes and solutions to consider when troubleshooting this issue.


Possible causes:

  1. Using AZInsight in multiview and opening multiple Amazon pages that will cause AZInsight or any other Amazon extension to run in the background at the same time.
  2. Using an extension that performs page scraping in a quick manner (for example ASINFetcher)
  3. Use similar Amazon extensions that scrape the amazon page in the background calling the same information (for example OSAddon Stock Checker and AZInsight)


Solutions to consider:

  1. Limit the number of pages. Do not open more than 5 Amazon product pages at one time when using the multiview mode on AZInsight Advanced
  2. Keep the number of extensions low. Refrain from running two extensions simultaneously that perform similar functions on the same browser
  3. Log out of your Amazon account. Simply log out of Amazon and Seller Central, this should be enough to allow you to keep using the website without seeing the dogs of Amazon error page.
  4. Use Amazon in incognito mode. Use your browser to open a new tab in Incognito Mode and use the website as you normally would do.
  5. Open a case with Amazon Support. Try to open a case with Amazon Support, is going to be difficult to try to open a case as when you try to use Seller Central or Amazon to open a case you will get the dogs of Amazon error page.
  6. Wait. Normally, after a few hours, the Amazon system will remove the flag from the user and you will be able to use the website as normal.


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